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Editing Fundamentals
In this chapter, you’ll learn how to use the Edit page to assemble new timelines from scratch and 
modify existing timelines that you’ve imported for finishing. Whether you’re using Resolve as an 
NLE to edit an entire program from scratch, as a dailies system to create quick rough 
assemblies for grading and transcoding, or as a finishing system with which to replace VFX 
clips, fix problems with an errant conform, and make last-minute re-edits to a program to be 
graded, the Edit page has many of the tools you’re accustomed to using in other editing 
environments, and a few that are unique to DaVinci Resolve. 

For more information on how to use the Edit page to import and conform projects edited in 
other applications for color correction and finishing in DaVinci Resolve, see Chapter 22, 
“Importing Projects and Relinking Media.”
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Creating and Duplicating Timelines
If you’re not importing a project that’s been edited elsewhere, you can create a new timeline to 
cut together a new edit from scratch, or to grade a set of dailies. When you create a new 
timeline, you can either create a timeline that contains all clips found in the Media Pool to 
quickly create a big batch of offline dailies, or an empty timeline that’s ready for you to add 
specific clips to.

Creating Blank Timelines
If you’re cutting a new program, you’ll want a blank timeline. However, it’s often useful to create 
blank timelines when putting together dailies. For example, you could create an empty timeline, 
sort the Media Pool by reel name, and add all clips from a particular reel to a dedicated timeline.

To create a new blank timeline:

1	 Select or create a Folder in the Bin list in which to put the new timeline (optional).

2	 Do one of the following:

�� Choose File > New Timeline (Command-N).

�� Right-click within the Media Pool, and choose Timelines > Create New Timeline.

3	 When the New Timeline Options window opens, set the following options:

�� Start Timecode: You can change the Start Timecode if a specific start time 
is required.

�� Timeline Name: Enter a name into the Timeline Name field.

�� No. of Video Tracks: Enter how many video tracks you want to have.

�� No. of Audio Tracks: Enter how many audio tracks you want to have.

�� Audio Track Type: Choose the audio track mapping you want the new audio 
tracks to have.

�� Empty Timeline: By default a new timeline will be empty. If you turn off the Empty 
Timeline checkbox, the new timeline that’s created will contain all the media found 
within the Media Pool.

�� Use Selected Mark In/Out: If you’ve selected one or more clips in the Media Pool, 
turning this checkbox on creates a new timeline and automatically populates it with 
the selected clips. Clips are edited according to the sort order of the Media Pool, and 
each clip’s duration matches that defined by the In and Out points of each clip.

4	 Click Create New Timeline.

A new timeline is created. If necessary, you can duplicate an existing timeline in order to alter 
an edit or create an alternate grade.

To create a timeline by dragging and dropping a clip:

�� Drag any clip into the empty Timeline area underneath the Viewers on the Edit page, 
and a new timeline will automatically be created.

To duplicate a timeline:

�� Right-click the sequence you want to duplicate in the Media Pool and choose Timelines 
> Duplicate Timeline from the contextual menu. A new timeline will appear in the list 
with “copy” appended to the name.
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Creating Timelines From Bins and Selections
The “Create Timeline Using Bin” and “Create Timeline Using Selected Clips” commands let you 
quickly assemble a timeline using the contents of the Media Pool, using whatever In and Out 
points have been added to each clip, and using the sort order of the enclosing bin to determine 
the order in which the clips will be assembled.

To create a timeline using the full contents of a bin:

1	 (optional) Put the Media Pool into List mode, set In and Out points for each clip in your 
Bin, and sort the Media Pool by the column that will put all clips in the order you want 
them to be assembled.

2	 Right-click the bin in the Bin list, and choose “Create Timeline Using Bin.”

3	 Type the name of the new timeline in the New Timeline Properties dialog. If you want 
to use the In and Out points of each clip, make sure “Use Selected Mark In/Out” is 
checked, and click Create New Timeline.

To create a timeline using manually selected clips:

1	 (optional) Put the Media Pool into List mode, set In and Out points for each clip in your 
Bin, and sort the Media Pool by the column that will put all clips in the order you want 
them to be assembled.

2	 Select one or more clips you want to assemble into a new timeline.

3	 Right-click one of the selected clips, and choose “Create Timeline Using Selected Clips.”

4	 Type the name of the new timeline in the New Timeline Properties dialog. If you 
want to use the In and Out points of each clip, make sure “Use Selected Mark In/Out” 
is checked, and click Create New Timeline.

TIP: These commands are especially useful for putting together quick assembly edits 
if you have metadata-rich media with scene, shot, and take information that you can 
use to sort clips into the proper order, and In and Out points that you’ve 
already logged.

Where Are Timelines Stored?

Ordinarily, timelines are created in the currently selected Media Pool bin. However, if 
you’d enabled “Use Timelines Bin” in the General panel of the Project Settings before 
you added anything to the Media Pool, a dedicated Timelines bin appears at the top of 
the Bin List, which contains all timelines in a project. 

When using the Timelines bin, you’re prevented from putting timelines into any other 
bin of the Media Pool. Whenever you create or import a new timeline, it automatically 
appears in the Timelines bin. You can add subfolders to the Timelines bin for more 
specific organization.

If you don’t want this kind of strict organization, but you would like an easy way to 
browse all the timelines in your project at once, regardless of their diverse locations, 
you can enable the “Create Smart Bin for Timelines” option, which is also in the 
General panel of the Project Settings. This creates a Smart Bin in the Bin List of the 
Media Pool that filters all timelines in your project, making it easy to see all your 
timelines without altering your original organization.
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Selecting Clips in the Media Pool to Edit
The following procedures show how to select one or more clips in the Media Pool to accomplish 
various editing tasks, either by opening a clip in the the Source Viewer, or selecting a group of 
clips with which you want to do drag and drop editing. This section starts by presenting 
different ways you can browse the contents of the Media Pool to find clips you want to use, in 
preparation for making a selection for your next operation.

Methods of browsing clips in the Media Pool:

�� Using thumbnail hover scrub in the Media Pool’s Thumbnail view: Drag the pointer 
over a thumbnail to scrub though its contents.

Thumbnail hover scrubbing

�� Using the Media Pool Filmstrip in the Media Pool’s List view: Select a clip to expose it 
in the Filmstrip at the top of the Media Pool, and hover the pointer over the Filmstrip to 
watch it play. At any time, you can double-click a clip in the Filmstrip to open it into the 
Source Viewer.

Using the Filmstrip when the Media Pool is in List view

Methods of selecting clips in the Media Pool:

�� To select a single clip using the mouse: Click a clip in the Media Pool with the mouse. 

�� To select a single clip using the keyboard: Use the Arrow keys to change the selection 
from clip to clip in the Media Pool, up, down, left, and right. If you’ve selected a folder, 
use the left arrow key to close the folder, and the right arrow key to open the folder. 
Once a clip is selected, you can press an edit keyboard shortcut to edit the selected 
Media Pool clip straight to the currently open timeline.

TIP: When browsing media, you can open clips you want to have a closer look at in the 
Source Viewer by double-clicking them in the Media Pool. Meanwhile, you can 
continue to open other clips in the Filmstrip with a single clip in order to compare 
different clips with your main selection that remains in the Viewer.
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�� To select a contiguous range of clips: In Icon mode, drag a selection box over all the 
clips you want to select. In Icon or List mode, select the first clip in a series, then Shift-
click the last clip to select those clips and everything in between.

Selecting a contiguous range of clips

�� To select a noncontiguous range of clips: Command-click each clip you want to include 
in the selection.

Selecting a discontiguous range of clips

�� To select all clips in the Media Pool: Make sure the Media Pool has focus, then press 
Command-A to select all clips.

Once you’ve opened a clip into the Source Viewer, you can use the transport controls to play 
through it.
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Transport Controls and 
Timeline Navigation
Once you’ve decided which clips you want to use in your program, you can open them into the 
Source Viewer to review them more completely.

To open a clip into the Source Viewer using the mouse:

�� Double-click any clip in the Media Pool, or in the Filmstrip of the Media Pool, to open it 
into the Source Viewer.

To open a clip into the Source Viewer using the keyboard:

1	 If necessary, press Command-4 to select the Folder List, and press the Up and Down 
arrows to choose a folder to view its contents. Press the Right Arrow key to open 
folders and show any nested folders within, or the Left Arrow key to close folders and 
hide their nested contents. 

2	 Press Command-5 to select the Media Pool browser, and use the Arrow keys to change 
the selection from clip to clip in the Media Pool, up, down, left, and right. 

3	 When the clip you want is highlighted, press Return to open it into the Source Viewer.

To open a timeline into the Source Viewer:

Drag and drop any timeline into the Source Viewer in preparation for either ganging it to the 
existing Timeline, or editing it, in whole or in part using In and Out points, into the currently 
open Timeline.

Transport Controls
The Edit page has two Viewers. The left Viewer, when you’re editing, should be set to show 
either source video or source audio, so it shows the source clip in any edit you’re setting up. At 
right is the Timeline Viewer, that shows the frame at the current position of the playhead in the 
Timeline. Using the Source and Timeline Viewers, you can set up a wide variety of edits.

There are identical transport controls underneath each of the Viewers.

The transport controls at the bottom of the Source Viewer

Monitoring With An External Video Display

While working in the Edit page, the image that’s displayed on an external video display 
(if one is connected) is determined either by the current selection in the Media Pool, or 
by which part of the Edit page interface has focus. For example, if you select a clip in 
the Media Pool so it’s displayed within the Filmstrip, that clip is output to video. If you 
then open it into the Source Viewer, then the contents of the Source Viewer are output 
to video. If you switch to the Timeline Viewer, then your timeline is output to video.
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A jog bar (sometimes called a scrubber bar) appears directly underneath the image, letting you 
drag the playhead directly with the pointer. The full width of the Source Viewer’s jog bar 
represents the full duration of a clip, while the full width of the Timeline Viewer’s jog bar 
represents the full duration of the current timeline. The current position of each playhead is 
shown in the timecode field at the upper right-hand corner of each viewer.

A separate jog control, to the left of the primary transport controls at the center, provides a way 
to jog more slowly through long clips or a long timeline. Click and drag to the left and right to 
move through a clip or the Timeline a frame at a time.

Transport controls appear above the jog bar. In the Source Viewer, these controls let you Jump 
to the First Frame, Play Reverse, Stop, Play Forward, and Jump to the Last Frame. In the 
Timeline Viewer, these control move to the Previous Edit, Play Reverse, Stop, Play Forward, and 
move to the Next Edit.  A loop control governs the looping behavior during playback.

Simple Keyboard Shortcuts for Playback and Navigation
There are many different keyboard shortcuts you can use to simply navigate clips and timelines, 
and control playback.

�� Spacebar: You can use the spacebar to start and stop playback.

�� Step Forward/Step Back: The Left Arrow and Right Arrow keys move back and forth 
one frame at a time, while Shift-Left Arrow and Shift-Right Arrow move the playhead in 
one second increments.

�� Next Edit/Previous Edit: Up Arrow moves the playhead to the previous edit and selects 
the edit point, while Down Arrow moves the playhead to the next edit and selects the 
edit point.

�� First and Last Frame of the Current Clip: The Semicolon key moves the playhead to the 
first frame of the clip intersecting the playhead, while the Apostrophe key moves the 
playhead to the last frame of the clip intersecting the playhead.

�� Previous Keyframe/Next Keyframe: Shift-Semicolon moves the playhead to the next 
previous keyframe on the left when keyframes are displayed in the Timeline, while 
Shift-Apostrophe moves the playhead to the next keyframe to the right.

�� Timeline Start/Timeline End: The Home key moves the playhead to the first frame of 
the Timeline, while the End key moves the playhead to the last frame of the Timeline.

�� In Point/Out Point: Shift-I moves the playhead to the In point set in either the Viewer or 
the Timeline. Shift-O moves the playhead to the Out point.

Using JKL to Control Playback
The JKL keyboard shortcuts are common to many editing applications, and experienced editors 
know these to be some of the most useful controls for playback and editing there are. Here’s a 
list of the many different ways you can use these three keyboard shortcuts to play through clips 
and timelines as you work.

TIP: One of the General Options in the Project Settings window, “Always highlight 
current clip in the media pool,” lets you decide whether the current selection in the 
Timeline is mirrored in the Media Pool.
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Key Function

J Plays 100% backward.

K Stops playback.

L Plays 100% forward.

Press J repeatedly Increases backward play speed each time you press J,  
for a range of fast-reverse speeds.

Press L repeatedly Increases forward play speed each time you press L,  
for a range of fast-forward speeds.

Shift-J Plays in fast reverse.

Shift-L Plays in fast forward.

K+J Plays backward at slow motion  
(with slow motion audio playback).

K+L Plays forward at slow motion  
(with pitch-corrected audio playback on OS X).

Pressing K while tapping J Moves the playhead back one frame.

Pressing K while tapping L Moves the playhead forward one frame.

Command-J  
and  
Command-L

Holding the Command key down while using the J and L 
keyboard shortcuts lets you dynamically resize or trim 
selected edit points or clips at 100 percent or faster speed, 
depending on whether the Selection or Trim tool is enabled. 
More information on dynamic trimming appears later in 
this chapter.

Once you learn all the different methods of JKL playback, they will probably become one of the 
main ways you move the playhead around in Resolve.

Special-Purpose Playback Commands
In addition to the standard transport controls, there are some additional playback controls, 
available via keyboard shortcuts or the Playback menu, that let you perform different playback 
operations.

�� Loop: Command-Forward Slash (/). Toggles looped playback off and on. While looped 
playback is on, playback initiated with any of the following commands will loop 
automatically until you stop playback.

�� Play around current frame: Forward Slash (/). Plays a section of the Timeline from x 
frames before to y frames after the current position of the playhead. This command 
is useful for previewing how edits play within the context of the clips immediately 
surrounding them. The pre-roll and post-roll time is customizable in the Editing panel of 
the Project Settings.
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�� Play around current clip: (no default key assigned). Plays a section of the Timeline 
from x frames before to y frames after the current clip intersecting the position of the 
playhead. The pre-roll and post-roll time is customizable in the Editing panel of the 
Project Settings. 

�� Play Around In: Option-Space. Plays a section of the Timeline from x frames before to 
y frames after the current assigned In point, letting you preview the transition from one 
clip to the next. The pre-roll and post-roll time is customizable in the Editing panel of 
the Project Settings.

�� Play Around Out: Shift-Space. Plays a section of the Timeline from x frames before to y 
frames after the current assigned Out point, letting you preview the transition from one 
clip to the next. The pre-roll and post-roll time is customizable in the Editing panel of 
the Project Settings.

�� Play In to Out: Option-Forward Slash (/). If you’ve marked a section of a clip or timeline 
with In and Out points, this command lets you preview how it will play.

�� Play to In: (no default key assigned). Initiates playback and stops at the current In point.

�� Play to Out: Option-Command-Option-Forward Slash (/). Initiates playback and stops at 
the current Out point.

Enabling and Disabling Audio Scrubbing
Audio scrubbing is enabled by default, meaning that you’ll hear audio when dragging the 
playhead with the mouse back and forth. While this can be useful when you’re searching for 
audio cues, it can also be distracting if you’re just focused on the picture.

To enable or disable audio scrubbing:

�� Choose Timeline > Audio Scrubbing (Shift-S)

Navigating Using Timecode
You can use absolute or relative timecode entry to either move the playhead in both the Source 
and Timeline Viewers, or to move or trim selected edit points or clips. When navigating the 
Timeline, timecode entry lets you move the playhead very precisely, or jump to specific 
timecode values really quickly.

When entering timecode, type each pair of hour, minute, second, and frame values from left to 
right, with a period representing a pair of zeros for fast entry. Press the Return key to execute 
the timecode command. 

�� The rules for timecode entry are as follows:

�� The right-most pair of timecode values (or period) you enter is always the 
frame number.

�� A period to the left of any number you type is considered to be a pair of zeroes. 
A single period between two numbers is considered to either be a single zero, or 
ignored if it’s between two pairs of numbers.

�� Any untyped pairs of values to the left of what you enter are assumed to be whatever 
those values were prior to the timecode you entered; this makes it easy to type partial 
timecode values even when the Timeline starts at hour one. 

�� It’s not necessary to enter colons or semicolons. 

Absolute timecode is entered simply by typing in a timecode value. So long as no clips or edit 
points are selected when you press the Return key, the playhead will move to that timecode 
value. If an edit point or clip is selected, those will be moved or trimmed to the corresponding 
timecode value, if possible.
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Here are some examples of absolute timecode entry using this method:

Original TC Value User-Typed Value New TC Value

01:10:10:10 15245218 15:24:52:18

01:10:10:10 2.. 01:02:00:00

01:10:10:10 15 01:10:10:15

01:10:10:10 12 01:10:10:12

01:10:10:10 1.2 01:10:01:02

01:10:10:10 115.. 01:15:00:00

01:10:10:10 23... 23:00:00:00

Relative timecode is entered by starting the timecode value with a plus (+) or minus (–). Adding 
a plus results in the value you type being added to the current timecode value for purposes of 
offsetting the playhead or moving a selection. Adding a minus will subtract the value you type 
from the current timecode value.

Here are two examples of  relative timecode entry:

�� +20	 00:00:20:00 is added to the current timecode value.

�� -5	 00:00:00:05 is subtracted from the current timecode value. 

Gang Viewers (Playhead Ganging)
Ordinarily, the playhead movement in the Source and Timeline Viewers is independent. 
However, if you click the Option menu at the upper right-hand corner of either Viewer and turn 
Gang Viewers on, the movement of the Source and Timeline Viewer playheads is locked 
together, so that they move in unison. 

This is useful when you’re marking the In and Out points of a clip in the Source Viewer to match 
the duration of a clip or other event in the Timeline.

Setting In and Out Points
Now that you’ve used playback commands to review your clips, you can place In and Out points 
to set the range of each clip that you want to edit into the Timeline. If you don’t set In or Out 
points, then the entire clip will be edited into the Timeline.

To set In and Out points using the Media Pool list view Filmstrip: 

Set the Media Pool to List view, then select a clip to expose it in the Filmstrip at the top of the 
Media Pool, drag the pointer through the Filmstrip to watch it play, and press I and O to set In 
and Out points to the appropriate range.



291Chapter 14  –  Editing Fundamentals

Marking In and Out points in the Filmstrip of the Media Pool in List view

Marking In and Out points in the Filmstrip of the Media Pool in List view

The Filmstrip will dim the heads and tails to let you see the range of media you’ve marked. 
Once you’ve marked In and Out points in the Filmstrip, you can drag them to the left and right to 
move them.

To set In and Out points in the Source Viewer:

1	 Open a clip in the Source Viewer, or select the Timeline Viewer. 

2	 Use keyboard shortcuts, the transport controls, or jog bar to move the playhead to 
where you want to set an In or Out point.

3	 Do one of the following:

�� To mark simple In and Out points: Use the In and Out buttons to the right of the 
transport controls, or press the I or O keys.

�� To mark split In and Out points in preparation for making a split edit: Right-click the 
Jog Bar and choose Mark Split > Video/Audio In/Out.

Marking In and Out points in the Source Viewer,  
both as simple (Top) and split edits (Bottom)

Simple In and Out points let you join the audio and video of two clips at a single edit point in the 
Timeline. However, setting split In or Out points sets you up to create split edits where the 
video is offset from the audio in a single step.
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To clear In and Out points:

�� To clear In or Out points: With the Source Viewer selected, press Option-I to clear the 
current In point, or Option-O to clear the current Out point.

�� To clear both the In and Out points at once: With the Source Viewer selected, 
press Option-X.

To jump the playhead to the current In or Out points: 

Press Shift-I to move the playhead to the current In point, 

Press Shift-O to move the playhead to the current Out point.

Once set, In and Out points remain in place within each source clip until you set new ones.

Working With the Timeline
Before you start editing clips into the Timeline, it’s a good idea to understand how to customize 
the Timeline’s view in different ways. Adding, rearranging, and removing tracks, zooming in and 
out, and scrolling around the Timeline are important to working efficiently.

Creating, Deleting, and Moving Timeline Tracks
When you’re getting ready to edit clips into the Timeline, you need to make sure you’ve got 
enough tracks to do the job. The following procedures cover the different methods available for 
adding, removing, and rearranging tracks as you work. 

These commands are all available via the contextual menu that appears when you right-click 
anywhere in the Timeline header area (the header of the Timeline is the area to the left where 
each track’s various buttons and controls are located).

Methods for adding, deleting, and rearranging tracks:

�� To add a track to the Timeline: Right-click anywhere in the Timeline header and choose 
Add Track. If you add an audio track, you can choose what type of channel mapping 
you want. For more information about audio track channel mappings, see Chapter 20, 
“Working With Audio.” 

�� To add multiple tracks to the Timeline at a specific position: Right-click anywhere in 
the Timeline header and choose Add Tracks. When the Add Tracks dialog appears, 
choose the number of video and audio tracks you want to add, choose the position you 
want to insert the tracks above or below, and choose the Audio Track Type you want to 
add if you’re adding audio tracks. When you’re done, click “Create New Tracks.”

�� To delete a track from the Timeline: Right-click within a track’s Timeline header and 
choose Remove Track. If there are clips on a track you remove, they are deleted from 
the Timeline.

�� To delete all unused tracks in the Timeline: Right-click anywhere in the track header 
area and choose Delete Empty Tracks. All tracks without clips will be deleted at once.

�� To move tracks and the clips on them up and down: Right-click within a track’s 
Timeline header and choose Move Track Up or Move Track Down from the contextual 
menu. That track, along with all clips on it, will be moved up or down relative to the 
other tracks in the Timeline.
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Using Snapping and Zooming
When preparing to make an edit into the Timeline, you can set the snapping and zoom controls 
to whichever state is most useful for the operation you need to perform. For example, if you’re 
editing an insert shot into a rapid-fire section of edits in the Timeline, you may want to zoom in 
to better see the exact place where you want to place the incoming clip. Since there are many 
edits at that point, disabling snapping might make it useful to avoid having the clip jump to the 
nearest edit point if you need to move the incoming clip to a very specific frame.

Playhead Snapping and Timeline Zoom:

�� To turn clip and playhead snapping on and off: Click the Snapping button in the 
toolbar, or press N. When snapping is turned on, the In and Out points and markers 
of clips all snap to one another and to the playhead. You can also press N to turn 
snapping on or off while dragging a clip in the Timeline. 

The snapping button in the toolbar

�� To zoom into and out of the Timeline: Drag the zoom slider to the left to zoom out, and 
right to zoom in. You can also press Command-Minus (–) and Command-Equal (=) to 
zoom out and in. Either way, zooming is always centered on the current position of the 
playhead, even if the playhead is off screen.

�� To frame every clip into the width of the Timeline: Press Shift-Z. This is a toggle, so 
pressing Shift-Z frames your whole edited sequence to the width of the Timeline, 
and then pressing Shift-Z again returns the Timeline to whatever level of zoom you 
were using previously. Using this keyboard shortcut makes it really easy to navigate 
the Timeline when you’re zoomed in, as you can press Shift-Z, move the playhead to 
another part of the Timeline you want to work on, and then press Shift-Z again to zoom 
back into the new location of the Timeline.

Scrolling Through the Timeline 
When you’re zoomed into the Timeline, you can scroll left and right, or up and down, using 
horizontal and vertical scroll bars. You can also scroll up and down the tracks of the Timeline 
using the scroll wheel of your mouse. You can also scroll within the Timeline by middle-clicking 
and dragging in any direction, which works the same as panning around a viewer that you’ve 
zoomed into. This frees you from having to use the scroll bars as you move around your 
edited clips.

If you scroll past the position of the playhead, a small playhead indicator appears in the bottom 
scroll bar to let you know where it is relative to the entire duration of your edited sequence.

 

A small indicator shows the position of the playhead  
if it’s outside of the visible area of the Timeline
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If you need to see more of the video or audio tracks in the available area of the Timeline, you 
can drag the horizontal divider that separates the audio and video tracks up or down to create 
room where you need it.

Dragging the Timeline center divider to make more room for audio or video tracks

Timeline View Options
As you’re working on an edit, it can often be useful to modify the appearance of the Timeline, 
changing the height of video or audio clips, choosing whether audio waveforms are drawn or 
not, etcetera. Using the Timeline View Options pop-up at the bottom right of the Timeline, you 
can make these kinds of changes as you work.

The Timeline View Options pop-up

You have the following options:

�� Track appearance buttons: Three buttons let you choose the overall appearance of 
video and audio tracks. From left to right, the options are: Video Filmstrips, Video tracks 
with thumbnails, Minimized tracks.

�� Show Audio Waveforms checkbox: Lets you turn audio waveform viewing off and on. 
When Audio Waveform is turned off, audio tracks are minimized.

�� Show Flags and Markers checkbox: Lets you turn the drawing of Flags and Markers 
off and on.
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�� Video track height slider: Lets you resize the size of all video tracks at once, 
independently of the audio tracks.

�� Audio track height slider: Lets you resize the size of all audio tracks at once, 
independently of the video tracks.

In addition, any track in the Timeline can be individually resized by dragging its top divider in 
the Track Header area.

Resizing an individual timeline track by dragging  
its top border in the Track Header

Assembling Clips in the Timeline
Once you’ve selected a clip to edit, marked In and Out points, and set up the Timeline for 
editing, it’s time to begin assembling your edited program together.

Drag and Drop Editing
The simplest method of editing is to drag clips from the Media Pool and drop them into the 
Timeline. You can do this with individual clips, or with selected groups of clips.

1	 If you need to edit more specific ranges of the clips you’re editing, you can set In and 
Out points in source clips first by doing one of the following:

�� Using the Media Pool Filmstrip in the Media Pool’s List view: Set the Media Pool to 
List view, then select a clip to expose it in the Filmstrip at the top of the Media Pool, 
drag the pointer through the Filmstrip to watch it play and press I and O to set In and 
Out points to the appropriate range. The Filmstrip will dim the heads and tails to let 
you see the range of media you’ve marked.

�� Using the Source Viewer: Open a clip in the Viewer by double-clicking it in the Media 
Pool, or selecting it in the Media Pool and pressing the Return key. Then use the 
transport controls, jog bar, or control panel buttons to move the playhead, and place 
In and Out points using the In and Out buttons to the right of the transport controls, or 
by pressing the I or O keys.

�� Using the Finder (OS X only): You can also drag one or more clips from the Finder 
directly onto a timeline track in Resolve.

2	 If you want to edit several clips at once, select them in the Media Pool after you’ve 
finished setting In and Out points.
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3	 Drag any of the following to the desired position in the Timeline to perform an overwrite 
edit: selected clips in the Media Pool; the clip in the Media Pool filmstrip; the clip in the 
Source Viewer; any selected clips in the Mac OS X Finder. The clip(s) you drag replace 
whatever was there before. Multiple clips dragged from the Media Pool will be edited in 
the order in which they’re sorted in the Media Pool, using each clip’s In and Out points.

Dragging multiple clips into the Timeline in the sort order of the Media Pool

Easy Drag and Drop Editing of Video- or Audio-Only Edits
While it’s easy to edit just the video or just the audio of a clip by disabling the audio or video 
destination control in the Timeline prior to doing any sort of edit (described later in this chapter), 
there’s also a pair of keyboard modifiers you can use to do the very same thing.

�� 	Option-drag clips from the Media Pool/Filmstrip, Source Viewer, or Finder into the 
Timeline for a video-only edit.

�� Shift-drag clips from the Media Pool/Filmstrip, Source Viewer, or Finder into the 
Timeline for an audio-only edit.

Three-Point Editing of Clips Directly from the Media Pool
If you want, you can edit clips directly into the Timeline from the Media Pool. This can be a fast 
way of appending clips to the end of the Timeline, but it’s also a useful way of performing other 
kinds of edits, as well.

To edit one or more clips from the Media Pool to the Timeline:

1	 If necessary, set In and Out points for each of the clips you want to edit into the Timeline 
using either the Media Pool Filmstrip Viewer (in List view), or by opening them into the 
Source Viewer. In either case, press I to set an In point, and O to set an Out point.

2	 If necessary, switch the Media Pool to List view and change the column you’re using to 
sort by to put the clips in the order in which you want them to appear for editing.

3	 Set In and Out points in the Timeline, or position the playhead to where you want to 
edit the clips.

4	 Click, drag, use the Command-Option and Command-Shift Up and Down Arrow Key 
shortcuts, or use the Option-1–8 and Command-Option-1–8 key shortcuts to assign the 
video and audio destination controls to the tracks you want to edit the video and audio 
of the incoming clip(s) to. Click any destination control itself to disable it if you want to 
edit clips into the Timeline as audio or video only.

5	 Select one or more clips you want to edit. Insert, Overwrite, Place On Top, Ripple 
Overwrite, and Append At End edits are all capable of editing multiple clips at once, 
while Replace and Fit to Fill edits can only edit one clip at a time, and will only edit the 
first of multiple selected clips into the Timeline.
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6	 To perform the edit, do one of the following:

�� Use any of the editing commands in the Edit menu.

�� Use the equivalent keyboard shortcuts to Insert (F9), Overwrite (F10), Replace (F11), 
Place On Top (F12), Ripple Overwrite (Shift-F10), Fit to Fill (Shift-F11), or Append To End 
of Timeline (Shift-F12) the selected clips into the Timeline.

�� Right-click one or more selected clips in the Media Pool, and choose “Insert Selected 
Clips to Timeline,” or “Append Selected Clips to Timeline.”

The selected clip(s) are edited into the Timeline.

Source/Record Editing
A more controlled form of editing is to use three and four point editing to make a specific range 
of source media fit into a specific range of the Timeline. 

Setting Destination Controls to Choose a Track to Edit Onto
The orange destination controls, found in the Timeline header area, let you specify which video 
and audio tracks you want incoming source clips to be edited to when you use editing methods 
other then drag and drop. No matter how many video or audio channels may be embedded 
within a single clip of media, only one video and one audio destination control is available. In 
the case of video, you can only expose one video channel of a clip at a time. In the case of 
audio, all audio channels for a given clip are embedded within a single Timeline track, making it 
a snap to edit stereo or other multi-channel audio sources together. (For more information 
about working with audio, see Chapter 20, ‘Working with Audio.”)

Setting the destination control of a track is a vital step in the process of creating an edit, and is 
easy to do. You can set the video and audio destination controls to be separate tracks.

To set the destination tracks of incoming source clips, do one of the following:

�� Click the destination control of any unassigned track to enable that track as the 
destination.

�� Drag the destination control to any unassigned track in the Timeline.

�� Press Command-Option Up Arrow and Down Arrow to move the Video Destination 
control up and down among different video tracks, or press Command-Shift Up Arrow 
and Down Arrow to move the Audio Destination control up and down among different 
audio tracks.

�� Press Option-1 through 8 to set a video destination, or press Option-Command-1 
through 8 to set an audio destination on tracks 1 through 8.

Moving the destination control to track V2, labeled “Titles”



298Chapter 14  –  Editing Fundamentals

You can also disable the Video or Audio Destination  controls in situations where you want to 
edit a source video clip into the Timeline without its audio, or vice versa.

To disable or reenable a destination control, do one of the following:

�� Click an already assigned destination control to toggle it off and then on again. 
Disabled destination controls are highlighted white.

A disabled destination control

Setting In and Out Points in the Timeline
When you’re setting up an edit to the Timeline, you can oftentimes get away with simply putting the 
Timeline playhead at the frame where you want to edit the incoming source clip. In the absence 
of In or Out points, the playhead is used as the In point. However, you can set up different kinds 
of edits by setting specific In and Out points to define different ranges of the Timeline.

Methods of setting and clearing In and Out points in the Timeline:

�� To set an In or Out point: Select the Timeline or Timeline Viewer by clicking or pressing 
the Q key, then use the transport controls, jog bar, or control panel buttons to move the 
playhead, and press the I key to set an In point, or the O key to set an Out point.

�� To clear In or Out points: With the Timeline Viewer selected, press Option-I to clear the 
current In point, or Option-O to clear the current Out point.

�� To clear both the In and Out points at once: Press Option-X.

�� To jump the playhead to the current In or Out points: Press Shift-I to immediately move 
the playhead to the current In point, or Shift-O to move the playhead to the current 
Out point.

In and Out points shown in the Timeline, with unmarked areas outside the selection dimmed
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Methods of moving In and Out points in the Timeline:

�� Press the I or O keys at any time to change the In or Out points.

�� Drag any In or Out point in the Timeline ruler to another position.

The area of the Timeline outside the region that’s currently defined by In and Out points is 
dimmed, to call attention to the portion of the Timeline that will be affected by the next edit 
you’ll make.

Mark Clip and Mark Current Selection
These commands are automatic ways of setting In and Out points in the Timeline both at once, 
using the timing of other clips. They’re both exceptionally handy for defining the range of an 
incoming edit using clips that are already in the Timeline that you want to replace, or gaps in the 
Timeline that you want to fill. 

In short, Mark Clip uses the first and last frame of a target clip or gap in the Timeline to 
automatically set Timeline In and Out points for editing. For example, if there’s a shot in an edit 
that you want to replace with a different take of the same action, or there’s a gap in a sequence 
of clips that you’d like to quickly fill with b-roll, you can use the Mark Clip command to help 
set this up.

Mark Current Selection uses the first and last frames of a range of selected clips to 
automatically set Timeline In and Out points for editing. A good example is when you have a 
series of clips in the Timeline, all of which you’d like to overwrite with a single incoming source 
clip, you can use the Mark Current Selection command.

To use Mark Clip:

1	 Move the playhead to intersect either a clip you want to use to set In and Out points, or 
a gap (empty area) between two other clips that you want to target. The playhead can 
be on any frame of this clip, it doesn’t matter which.

Positioning the playhead at a clip you want to mark

2	 If there are other clips on a multi-track timeline that overlap the clip you’re targeting 
for this operation, then the clip on the lowest video track will be used as the target 
to set the In and Out points. If you want to target a clip on a higher track, then either 
disable the Auto Selection controls of all timelines underneath, or Option-Click the Auto 
Selection control of the track with the clip you’re targeting to solo it, which will force that 
track to be the target of this operation.

3	 Press the X key to automatically set In and Out points that match the first and last 
frames of the target clip.
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Using Mark clip to set In and Out points that match a clip’s duration

To use Mark Selection:

1	 Select one or more clips in the Timeline.

Selecting clips you want to use as a range to mark In and Out points

2	 Press Shift-A to automatically set In and Out points that match the first and last frames 
of the selection. A range of discontinuous clips will produce the same result as a range 
of continuous clips

Marking a selection to set In and Out points

TIP: To clear both In and Out points, press Option-X, which is the opposite of 
this command.
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Assembling a Simple Sequence of Clips Using 
Overwrite Edits
Overwrite edits are by far the most common type of edit in most projects. They’re flexible in 
that you can eliminate unwanted material in other clips while at the same time adding new clips 
to the Timeline. The following example shows how you can use the Edit page to assemble a 
quick first cut of edits using different features of the Media Pool, Viewers, and Timeline.

1	 Open a clip into the Source Viewer, and set In and Out points to define the section of 
that clip you want to edit into your program.

2	 Click the destination control of the Timeline tracks you want to edit the incoming media 
onto. By default, the destination controls are assigned to tracks V1 and A1.

3	 To perform the edit, do one of the following:

�� Drag the clip from the Source Viewer to Timeline Viewer and drop it on the 
Overwrite overlay.

�� Click the Overwrite Clip button at the middle of the Toolbar.

�� Choose Edit > Overwrite (F10).

The selected clip(s) are overwritten to the selected track at the position of the 
playhead, and the playhead automatically moves to the end of the newly edited clip, 
ready for you to perform another edit. If that clip is the last one on the Timeline, you’ll 
see the last frame to the left of the playhead instead of the black that is the actual 
frame after that clip to make it easier for you to line up the next edit. Otherwise, the 
playhead will show whatever frame happens to be at that point in time.

4	 Open the next clip you want to edit into the Viewer, set In and Out points, and use the 
Overwrite Clip button or command to edit it into the Timeline. Continue this process 
until you’ve edited together the assembly of edits you want.

Three-Point Editing
Three-point editing is a standard editorial method that’s shared with many other postproduction 
applications, so this procedure should feel familiar. The idea is that you need only set any 
combination of three In and Out points in the source clip and Timeline to edit a clip into your 
program at a specific time, and Resolve automatically figures out the fourth edit point that’s 
necessary to execute the edit. Three-point editing is most commonly accomplished using 
Overwrite and Insert edits. 

In the previous example of assembling a simple sequence of clips, three point editing was 
being used by virtue of source In and Out points being set to define a range of the source clip 
to be edited into the Timeline, and the Timeline playhead being used as the acting Timeline In 
point; three points defined the edit to be made. However, three point editing is also very useful 
when you need to overwrite sections of a previously edited timeline with new source clips in a 
controlled manner, such as when adding an insert shot to a scene to cover a particular change 
you’re making that would break continuity.

Depending on the combination of Source and Timeline In and Out points you set, the following 
rules govern three-point editing:
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�� If there is no In point in the source clip: The first frame of media will be used as the 
acting source In point. This can be seen by the thick bar that extends to the left of the 
Out point in the Source Viewer’s jog bar.

A thick bar indicates which part of the source clip will be used in the absence of a Source In point

�� If there is no Out point in the source clip: The last frame of media will used as the 
acting source Out point. This can be seen by the thick bar that extends to the right of 
the In point in the Source Viewer’s jog bar.

A thick bar indicates which part of the source clip will be used in the absence of a Source Out point

�� If there are no In or Out points in the Timeline: The playhead will be used as the acting 
Timeline In point.

�� If you set a Timeline In point but no Timeline Out point: The whole range from the In to 
Out points of the source clip is edited into the Timeline such that the Source In point is 
aligned with the Timeline In point. This can be seen by the thick bar that extends to the 
right of the In point in the Timeline Ruler. 

A thick bar indicates where the Source clip will be edited in the absence of a Timeline Out point

�� If you set a Timeline Out point but no Timeline In point: The incoming source clip 
will be backtimed so the Out point of the source clip is aligned with the Timeline Out 
point. This can be seen by the thick bar that extends to the left of the Out point in the 
Timeline Ruler.
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A thick bar indicates a backtimed edit in the absence of a Timeline In point

�� If you set Timeline In and Out points but only a Source Out point: In this case, the 
incoming source clip will also be backtimed so the Out point of the source clip is 
aligned with the Timeline Out point, with the Timeline edit points defining the duration 
of the source clip being edited.

�� If you set all four Source In and Out and Timeline In and Out edit points: The Timeline 
edit points dictate the duration of source clip that is edited into the Timeline, and the 
frame at the Source In point is aligned with the Timeline In point, unless you perform a 
Fit to Fill or Ripple Overwrite edit, both of which can be done as four point edits.

Preview Markers During Three-Point Editing
In order to help you see what will happen whenever you execute a three-point edit, preview 
markers appear in either the Source Viewer or the Timeline Ruler to let you know the exact 
duration of the Timeline that’s about to be affected by the edit you’re preparing to make. To 
prevent them from being a distraction, preview markers only appear once you’ve explicitly 
marked three edit points in the Source Viewer and Timeline, and they can be turned on and off 
by choosing View > Show Preview Marks.

For example, if you set In and Out points in the Source Viewer, and an In point in the Timeline, 
then a preview marker will appear in the Timeline Ruler to show the implied Out point in the 
Timeline of the edit you’re about to make.

TIP: If you want to use all four Source and Timeline edit points to retime a source clip 
to fit into a specific range of the Timeline, use a Fit-to-Fill edit instead of an 
Overwrite edit.
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A preview marker in the Timeline shows the Timeline Out point being automatically calculated by  
Resolve based on the In and Out points that are set in the Viewer, and the In point in the Timeline

On the other hand, if you set both In and Out points in the Timeline, and only an Out point in the 
Source Viewer, a preview marker appears in the jog bar of the Source Viewer to show you the 
implied In point, in the Source Viewer, of the edit you’re about to make.

 

A preview marker in the Source Viewer shows the Source Viewer In point being automatically 
calculated by Resolve based on the In and Out points that are set in the Timeline, and the In point in 
the Source Viewer

If you like, you can move the playhead to the position of the preview marker by using Shift-I if 
the preview marker is an In point, or Shift-O if the preview marker is an Out point.
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Editing Rules for Split In and Out Points
If you’ve created split In and Out points in the Source Viewer or Timeline, the following 
rules apply:

�� If the Source Viewer has split In and Out Points: The leftmost split point of the incoming 
clip, whether video or audio, will be aligned with the playhead when the clip is edited; 
the other split point will be offset to the right.

�� If the Timeline has split In and Out Points: The In point of the incoming clip will be 
aligned with the left-most split point, whether video or audio; the accompanying audio 
or video In point will be offset to the split point to the right.

Editing a Specific Range of the Source Clip Into 
the Timeline
This section provides some common examples of three-point editing when performing edits in 
the middle of a previously edited timeline. In the following example, you have a specific range 
of source media that you need to edit into the Timeline, and you don’t particularly care what 
gets overwritten in the Timeline by the incoming clip.

1	 Set In and Out points in a source clip, either in the Media Pool or in the Source Viewer.

Setting source clip In and Out points

2	 To set where you want the incoming clip to go, set the destination control to the tracks 
you want to edit onto, and then do one of the following:

�� Move the Timeline playhead to the frame you want to use as the Timeline In point 
for the edit.

�� Set a Timeline In point for the edit.

Setting a Timeline In point
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3	 To make the edit, click the Overwrite Clip button in the toolbar, press the F10 key, or 
drag a clip onto the appropriate overlay in the Timeline Viewer.

The resulting edit; the duration of the source clip defines the duration of the edit

Editing Part of a Source Clip to Fit Into a 
Specific Range of the Timeline
In this example, you have a section of a clip or a gap in the edited sequence of clips in the 
Timeline that you want to fill with as much of the current source clip as it will take to “plug 
the hole.”

1	 Set an In point in the source clip, if necessary, to define the first frame of the range of 
source media that you want to edit into the Timeline.

Setting a source clip In point only

2	 Set In and Out points in the Timeline to set both where you want the incoming clip to 
go, and how much of the incoming clip you want to use.
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Setting both In and Out points of the Timeline for a gap

3	 To make the edit, click the Overwrite Clip button in the toolbar, press the F10 key, or 
drag a clip onto the appropriate overlay in the Timeline Viewer.

The resulting edit; the duration of the Timeline edit points define how much of the source clip is edited

Backtiming a Source Clip When Editing Into the Timeline
In this last example, you’ve got a specific moment in the second half of a source clip that you 
need to align with an Out point in the Timeline, such that the remaining duration of the incoming 
clip overwrites the edited sequence of clips from the right to the left. This is referred to as 
backtiming, when you’re lining up a Source Out point with a Timeline Out point in order to make 
an edit, and can be set up one of two ways.

Backtiming method one:

1	 Set In and Out points in the source clip, either in the Media Pool or in the 
Source Viewer.

2	 Set an Out point in the Timeline, at the frame where you want the corresponding Out 
point of the incoming source clip to be aligned.
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Setting up a backtimed match-on-action edit via In and Out points in the Source Viewer,  
and only an Out point in the Timeline

3	 To make the edit, click the Overwrite Clip button in the toolbar, press the F10 key, or 
drag a clip onto the overwrite overlay in the Timeline Viewer.

The resulting edit, aligning the Out point of the source clip with the Out point of the Timeline

Backtiming method two:

1	 Set an Out point in the source clip, either in the Media Pool or in the Source Viewer.

2	 Set In and Out points in the Timeline to set both where you want the incoming clip to 
go, and how much of the incoming clip you want to use.

 

Setting up a backtimed edit by setting an Out point in the Source Viewer, and  
In and Out points in the Timeline to define the duration of the edit
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3	 To make the edit, click the Overwrite Clip button in the toolbar, press the F10 key, or 
drag a clip onto the appropriate overlay in the Timeline Viewer.

The resulting edit, aligning the Out point of the source clip with the Out point of the Timeline

Switch Focus to Timeline After Edit
A setting in the Edit menu, “Switch focus to timeline after edit,” lets you set whether or not 
Resolve changes the application focus from the Source Viewer to the Timeline Viewer/Timeline 
every time you make an edit. This setting is on by default.

For example, if you’re assembling clips from many different source files into the Timeline, and 
trimming the results as you go, leaving this option on may save you time. In this case, after 
every edit, the focus switches from the Source Viewer to the Timeline, so you can quickly select 
the clip or edit point you want to trim and make your adjustments before loading the next clip 
into the Source Viewer in preparation for the next edit.

On the other hand, if you’re editing several pieces from a long interview clip into the Timeline, 
you may want to turn this setting off to make it easy to continue playing forward in the Source 
Viewer, setting In and Out points and editing clips into the Timeline as you go. After every edit, 
focus remains on the Source Viewer, so you can continue making edits from the same source 
clip without interruption.

Different Types of Edits
This section covers the different types of edits that are available for cutting source clips into the 
currently open Timeline.

Overwrite Edits
The most common type of edit you’ll make, an overwrite edit eliminates whatever media was in 
the Timeline previously with the incoming source clip taking the place of whatever was there. 
Overwrite edits are commonly used when initially assembling clips, or doing three-point editing.

Overwrite edits do not ripple the Timeline.

To overwrite one or more clips in the Timeline:

1	 Move the playhead to the frame of the Timeline where you want to insert a clip.

2	 Click the appropriate audio and video destination controls of the tracks you want to edit 
the incoming source clip onto. If necessary, create new tracks.

3	 Select a single clip in the Media Pool to open it into the Source Viewer, then set In and 
Out points to define the range of media you want to insert.

4	 To make the edit, choose Edit > Overwrite, click the Overwrite Clip button in the toolbar, 
press the F10 key, or drag a clip onto the Overwrite overlay in the Timeline Viewer.

The selected clips in the Media Pool are overwrite edited to the selected track starting 
at the position of the playhead, eliminating whatever was there originally while adding 
incoming clip. No other clips are rippled during this operation.
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Before and after an overwrite edit, the Timeline duration stays the same

Insert Edits
An insert edit splits whatever media is already in the Timeline at the position of the playhead, 
and pushes that media to the right to make room for the incoming clip.

Insert edits have the effect of rippling almost all clips in the Timeline that are to the right of the 
Insert Edit point you’re making, pushing them further to the right by the duration of the incoming 
source clip. However, clips in any tracks of the Timeline that overlap to the left of the Insert Edit 
point aren’t rippled, and remain in place.

For example, if you’re insert editing a clip into the middle of a sequence of clips in track V1 and 
A1 of the Timeline, and there’s also a clip of music edited into track A2 that overlaps well to the 
left of the insert edit point, the music clip remains where it is, but the other clips on track V1 and 
A1 that are to the right of your edit point on are pushed to the right.

To insert edit one or more clips into the Timeline:

1	 Move the playhead to the frame of the Timeline where you want to insert a clip.

2	 Click the appropriate audio and video destination controls of the tracks you want to edit 
the incoming source clip onto. If necessary, create new tracks.

3	 If necessary, set In and Out points in the clip or clips you want to insert edit into the 
Timeline using the controls of the Media Pool or the Source Viewer.	

4	 Do one of the following:

�� Select one or more clips in the Media Pool, right-click one of the selected clips, and 
choose “Insert Selected Clips to Timeline.” 

�� Choose Edit > Insert, click the Insert Edit button in the toolbar, press the F9 key, or 
drag any clip onto the Insert overlay in the Timeline Viewer.
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The selected clips are insert edited to the selected track at the position of the 
playhead, pushing all other media in the destination track back by the total duration of 
the selected clips, except for clips on other tracks that overlap to the left of the edit 
point (as seen by the overlapping music clip in the example below).

Before an overwrite edit 

After an overwrite edit, the Timeline gets longer as non-overlapping  
clips to the left of the edit point are rippled to the right

Replace Edits
A replace edit automatically replaces a clip in the Timeline with a clip in the Source Viewer, 
using the duration of the Timeline clip to define the duration of the incoming media, and the 
positions of the Viewer and Timeline playheads to line up how the incoming media should 
be placed.

You can also use a replace edit to edit a clip into an empty track of the Timeline so that the 
frame at the position of the Source playhead is aligned with the Timeline playhead, and the In 
and Out points of the incoming clip fall where they may. This is useful when you want to “spot” a 
particular action of an alternate take or a cue in a sound effect to a specific frame of 
the Timeline.

Replace edits do not ripple the Timeline.

To replace a clip in the Timeline:

1	 Move the playhead in the Timeline to the clip that you want to replace, and align it with 
a frame that you want to line up with a frame in the clip you want to replace edit into 
the Timeline.

2	 Click the appropriate audio and video destination controls of the track containing the 
clip you want to replace.

3	 Open a clip into the Source Viewer.

4	 Move the playhead in the Source Viewer to the frame that you want to line up with the 
frame at the position of the playhead in the Timeline.
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In the example shown below, the original clip that was shot on location of a car driving 
past a slab of real concrete (shown in the Timeline Viewer at right) is going to be 
replaced by a VFX shot of a concrete wall with a small hole for the car to drive through 
(shown in the Source Viewer at left). The playhead in the Source Viewer is aligned on 
the very same frame as the playhead in the Timeline Viewer, which can be seen by the 
identical position of the white stripe on the road in the lower right-hand corner of 
the picture.

In the Source Viewer to the Left is a VFX clip we want to edit into the Timeline to  
replace the existing Timeline clip,  shown in the Timeline Viewer at Right

5	 Now that the playheads are aligned on the frames that must match one another in 
both the Source and Timeline Viewers, choose Edit > Replace, click the Replace 
Clip button in the toolbar, press F11, or drag any clip onto the Replace overlay in the 
Timeline Viewer.

The resulting replace edit, in which the original timeline clip is replaced by the  
incoming Source Viewer clip by aligning the frames at each playhead

The camera original clip in the Timeline is now replaced with the VFX source clip from 
the Media Pool, with the source frame at the Source Viewer playhead aligned with the 
frame at the Timeline playhead.

Fit to Fill
Fit-to-fill edits are the only edit type that actually use all four edit points, and it’s the only edit 
type that retimes clips at the same time as they’re being edited. By setting In and Out points in 
the incoming source clip, and another pair of In and Out points in the Timeline, you can stretch 
or compress the timing of the specified range of source media to cover the entire specified 
range of the Timeline. In the process, the speed ratio of the clip changes so the clip plays in 
either fast or slow motion.
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Fit-to-fill edits are especially valuable when you have a source clip in which the action is slightly 
slow, and you just want to speed it up by squeezing it into a shorter duration of the Timeline. 
They’re also incredibly handy in situations when you have a gap in an edited sequence of clips 
to fill with a source clip that’s just not long enough, but in which slightly slower motion won’t be 
noticeable.

Fit-to-fill edits do not ripple the Timeline.

To use Fit-to-fill to edit a clip into the Timeline:

1	 Do one of the following to define where in the Timeline to edit the incoming clip: 

�� You can set both In and Out points in the Timeline, to define the duration you want to 
fill with the incoming source clip as a three point edit.

�� You can clear the Timeline In and Out points (pressing Option-X), so that you can 
instead use the duration of whichever clip or gap intersects the playhead on the 
track with the destination controls assigned to them. In the following screenshot, the 
clip can easily be edited to take the place of the gap by positioning the playhead 
anywhere within it. 

Setting timeline In and Out points to mark a gap

2	 Next, you’ll need to set both In and Out points in the Source Viewer to define a longer 
or shorter source clip that you want to fill into the available space. In this example, we 
have a very short section of the source clip defined that, because of the matching 
action in the Timeline, must be fit into the larger gap seen above.

Setting In and Out points in a source clip to define a shorter  
duration segment that you want to completely fill the gap

3	 Click the audio and video destination controls of the tracks you want to edit the 
incoming source clip onto. If necessary, create new tracks.

4	 Choose Edit > Fit to Fill, drag any clip onto the Fit-to-Fill overlay in the Timeline Viewer, 
or press Shift-F11.



314Chapter 14  –  Editing Fundamentals

The resulting edit; the shorter source clip is retimed to fit into the longer timeline gap

The incoming source clip is retimed, as necessary, to fit into the specified duration of 
the Timeline. This can be seen by the retiming badge that appears within the clip that’s 
just been edited into the Timeline.

Place On Top
Place-on-top edits automatically superimpose clips onto the first empty track above any other 
clips in the Timeline that either intersect the playhead or fall in between the currently set 
Timeline In and Out points, regardless of the current track specified by the destination controls. 
It’s designed to make it easy to superimpose titles and other clips you want to composite over 
another clip, or to add additional versions of clips such as VFX on top of previous versions that 
you want to preserve.

Place-on-top edits create new timeline tracks if necessary, and do not ripple the Timeline.

To use Place-on-top to edit a clip into the Timeline:

1	 To choose where in the Timeline the clip will be “placed on top,” do one of the 
following:

Move the playhead to intersect the clip you want to edit the incoming source clip 
on top of.

Set In and Out points in the Timeline to define the duration within which you want to 
place the incoming source on top.

2	 Set In and Out points in a source clip that you want to edit.

3	 Choose Edit > Place on Top, drag any clip onto the Place-on-Top overlay in the Timeline 
Viewer, or press F12.
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Before and after using Place on top, the incoming text generator is superimposed  
to a track above the clip at the position of the playhead

Incoming video clips will be edited to the topmost video track so they are above any 
previously existing video in the Timeline. Incoming audio clips are edited to the 
bottom-most audio track so they are below any previously existing audio. If necessary, 
new video and/or audio tracks will be created automatically to hold the new 
incoming clip.

Ripple Overwrite
Ripple Overwrite is a four-point edit that’s useful when you can identify a segment of the 
Timeline you want to overwrite, but the incoming clip is of a different duration and you want 
Resolve to automatically ripple the Timeline to accommodate the difference.

You can use the Ripple Overwrite command one of two different ways:

�� You can overwrite an entire clip in the Timeline with a another clip of different length.

�� You can overwrite a section of the Timeline marked with In and Out points with a 
another clip of different length. 

In both cases, all clips to the right of the clip or timeline section being overwritten are rippled to 
the right or left to make room or fill the gap. Because of this, the Ripple Overwrite edit will most 
likely change the overall duration of your edited sequence of clips.

Using Ripple Overwrite on an Entire Clip in the Timeline
Using Ripple Overwrite as an automatic four-point edit, you can overwrite whichever clip in the 
Timeline intersects the playhead on the tracks defined by the destination controls, in its 
entirety, with the incoming clip. For this to work, there must be no In or Out points set in 
the Timeline.

After performing a Ripple Overwrite in this way, the original timeline clip is eliminated and the 
incoming clip takes its place, and all clips to the right of the clip being replaced are either (a) 
rippled to the right if the incoming clip is longer then the original timeline clip, or (b) rippled to 
the left if the incoming clip is shorter than the original timeline clip. All of this is done in a 
single step.

This is useful in situations where you want to quickly switch one clip in the Timeline with another 
of unequal duration, and have the Timeline automatically make room to allow this all in one step.
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To use Ripple Overwrite to replace an entire clip in the Timeline with another source clip:

1	 Move the playhead in the Timeline to intersect the clip that you want to replace; the 
playhead’s exact position is not important.

2	 Click the appropriate audio and video destination controls of the track containing the 
clip you want to replace, and press Option-X to eliminate any In and Out points there 
might be in the Timeline.

3	 Open a clip into the Source Viewer, and set In and/or Out points as necessary to define 
how much of the clip you want to edit into the Timeline.

4	 To execute the edit, choose Edit > Ripple Overwrite, drag the clip to the Ripple 
Overwrite overlay of the Timeline Viewer, or press Shift-F10.

Before and after of using Ripple Overwrite with no Timeline In or Out points; Clip K at the position of 
the playhead is replaced in its entirety by the short segment of Clip U from the Source Viewer; all clips 
with In points to the right are rippled to the left to fill the gap

Using Ripple Overwrite on a Section of the Timeline
You can also use Ripple Overwrite as an explicit four-point edit, to overwrite a section of the 
Timeline that’s marked with In and Out points with an incoming clip that’s also marked with In 
and Out points that is of unequal duration. 

After performing a Ripple Overwrite in this way, the section of the Timeline marked with In and 
Out points is eliminated and the incoming clip takes its place, and all clips to the right of the clip 
being replaced are either (a) rippled to the right if the incoming clip is longer then the original 
timeline clip, or (b) rippled to the left if the incoming clip is shorter then the original timeline clip. 
All of this is done in a single step.

A good example of when this can be useful is when you’re cutting a close-up of an actor 
performing a particular action into a medium shot of the actor performing the same action that’s 
already in the Timeline, and the action you’re matching is of different durations in each of 
the shots.
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To use Ripple Overwrite to replace a section of the Timeline with another source clip:

1	 Set In and Out points in the Timeline to mark what part of the clip or clips you want 
to overwrite. You must set both In and Out points for this to work as expected. In this 
example, the part of the clip where the woman leans forward is marked.

Setting In and Out points to identify an action in the Timeline that you  
want to overwrite with another clip that has a matching action

2	 Open a clip into the Source Viewer, and set In and/or Out points as necessary to define 
how much of the clip you want to edit into the Timeline. In this example, a section of the 
woman’s close up where she leans forward in a way that matches the same movement 
in the wider shot is marked.

Setting In and Out points to identify an action in a source clip that you want to overwrite the action 
you’ve marked in the Timeline. It’s a matching action, but the timing might be different, and that’s okay 
with this kind of edit.

3	 To execute the edit, choose Edit > Ripple Overwrite, drag the clip to the Ripple 
Overwrite overlay of the Timeline Viewer, or press Shift-F10. As a result, the section of 
the timeline that was marked in step 1 is overwritten by the section of the source clip 
marked in step 2, and all clips to the right of this edit in the Timeline are rippled to the 
right to make room for the much longer source clip. The final result is an edit where the 
movements match nicely.
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After the Ripple Overwrite, the part of the Timeline clip marked with In and Out points has been 
overwritten by the part of the Source clip marked with In and Out points, and all clips to the right of this 
edit in the Timeline are rippled left or right as necessary

Append at End
Append at End always puts the edited clip at the very end of the current Timeline. It’s a very 
useful edit type when you’re quickly stringing together a series of clips.

To use Append at End to edit a clip into the Timeline:

1	 Set In and Out points in a source clip that you want to add to the end of the current 
Timeline.  If necessary, change the sort order of the Media Pool to put these clips into 
the order in which you want them to be added to the Timeline.

2	 Click the audio and video destination controls of the tracks you want to edit the 
incoming source clip onto. If necessary, create new tracks.

3	 Choose Edit > Append to End Of Timeline, drag the clip to the Append At End overlay 
of the Timeline Viewer, or press Shift-F12.

Insert Selected Clips to Timeline With Handles
“Insert Selected Clips to Timeline With Handles” is a command that’s available from the Media 
Pool contextual menu for editing one or more selected clips to the currently open timeline, such 
that the default handles length is subtracted from the beginning and end of each clip. The goal 
is to make it easy to string together a series of clips that you want to connect using transitions 
by automatically changing the In and Out points of each clip being edited into the Timeline in 
order to add handles. 

To use Insert Selected Clips to Timeline With Handles to edit one or more clips into 
the Timeline:

1	 Select one or more clips in the Media Pool that you want to add to the Timeline. If 
necessary, change the sort order of the Media Pool to put these clips into the order in 
which you want them to be added to the Timeline.

2	 Click the audio and video destination controls of the tracks you want to edit the 
incoming source clip onto, and position the playhead where you want the incoming 
clips to start. If necessary, create new tracks.

3	 Right-click one of the selected clips in the Media Pool and choose “Insert selected clips 
to timeline with handles” from the contextual menu.

The selected clips are added to the Timeline starting at the position of the playhead.
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To change the length of handles that are removed, open the Editing panel of the Project 
Settings and change the “Default handles length” setting. Handles will not be added in either of 
the following two cases:

�� If any of the selected clips in the Media Pool already have handles because of In and 
Out points that you’ve set, then additional handles won’t be added.

�� If the duration of the frames to be removed to create handles in this operation is greater 
than the duration of one or more of the clips you’ve selected in the Media Pool, then 
handles won’t be added at all.

Subclips
Subclips give you another way of organizing media in the Media Pool, letting you break 
excessively long clips into shorter ones. For example, if the director of a project is fond of 
“rolling takes” where multiple takes are all recorded within a single clip, you can break these 
takes up by making them into subclips.

To create a subclip:

1	 Do one of the following to open a clip into the Source Viewer in either the Media page 
or the Edit page, in preparation for creating subclips.

�� Double-click any clip in the Media Pool.

�� Single-click any clip in the Media Library of the Media page to create a subclip without 
needing to first import that clip into the Media Pool.

2	 Set In and Out points in the Source Viewer to define the section you want to turn into 
a subclip.

3	 Right-click the jog bar and choose Make Subclip from the contextual menu.

A new subclip appears in the Media Pool, automatically selected so that you can 
immediately edit its metadata in the Metadata Editor.

Once created, subclips appear and work like any other clip in Resolve. You can also create 
subclips in the Media page while performing other organizational tasks there.


